Savage Mark II GL .22 fail to eject question

Discussion in '.22-Rimfire Forum' started by garyg, Mar 18, 2006.

  1. garyg

    garyg New Member

    Joined:
    Feb 2, 2005
    Messages:
    41
    Location:
    Western PA
    I read a posting that indicated the Savage Mark II GL , left hand bolt .22, had a fail to eject the spent cartridge problem. I ordered this rifle two days ago and would like to know if anyone has info on this. Do any of you guys have one and have any knowledge of this. Thanks for any input. Gary
  2. corpis66

    corpis66 New Member

    Joined:
    Dec 12, 2002
    Messages:
    259
    Location:
    central MS
    i had a problem with mine, but i kept tinkering with it.. i did trigger jobs and such, so it was MY fault it didnt work, then i realized that the magazine well was just a tad crooked from when i tightened it down.. you may want to take it out of the stock, and check with a fired shell. :( tis a PITA process. or else it could be a defective extractor?... could give the place wherre you got it a visit, or call Savage themselves...
    BTW i'd have 3 savage rifles, 2 .22 and 1 .17hmr, and were all exceptional quality!
    hope you get it working right!
Similar Threads
Forum Title Date
.22-Rimfire Forum Savage Mark II Dec 8, 2013
.22-Rimfire Forum Savage MarkII Bolt question Jul 18, 2013
.22-Rimfire Forum Savage Mark II Feb 1, 2013
.22-Rimfire Forum Savage Mark II BV stock plans Sep 6, 2012
.22-Rimfire Forum Savage Mark II models Apr 26, 2012