Savage model 187J not cycling

Discussion in 'Technical Questions & Information' started by smilts, Jun 4, 2012.

  1. smilts

    smilts New Member

    Joined:
    Jun 4, 2012
    Messages:
    2
    I have a Savage Model 187J. The problem I'm having is when fired it will load the next shell but wont reset the trigger and firing pin. Everything seems solid in it. When I got it, it was really dirty and not ejecting or loading. Any ideas? Im thinking maybe it needs replacment springs if I can find them?
  2. Jim K

    Jim K New Member

    Joined:
    Dec 6, 2009
    Messages:
    6,400
    Have you tried different ammo? Those rifles are ammo sensitive, even when they are working right, which is not always.

    Jim
  3. Hawg

    Hawg Active Member

    Joined:
    Mar 23, 2011
    Messages:
    1,978
    It sounds like the bolt isn't traveling back far enough. Have you removed the bolt and cleaned it's travel area? If that's not the problem try some CCI Mini Mags. If it works with them it's an ammo problem. I have an 87B and it works almost all the time with Federal bulk, not at all with Remington but always without a hitch with CCI.
  4. smilts

    smilts New Member

    Joined:
    Jun 4, 2012
    Messages:
    2
    Yes Ive stripped the gun down completely. Cleaned and smoothed any rough areas, I took extra time to polish and smooth the bolt track. Then stripped the old bluing and re blued it. Ive only shot remington shells through it but will try the CCI mini mags. thank you both.
Similar Threads
Forum Title Date
Technical Questions & Information Savage model 4 .22 Apr 1, 2014
Technical Questions & Information Savage Model 99m Dec 28, 2013
Technical Questions & Information need help with Stevens/Savage model 311 double, safety mechanism Oct 24, 2013
Technical Questions & Information Springfield/Savage Model 120 Extraction Mystery Jan 28, 2013
Technical Questions & Information HELP! I need measure for a savage model 6a Dec 29, 2012