The Firearms Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5,160 Posts
Discussion Starter #1
Anyone with a Axis2 have this problem? All ammo(reloads) shot in it has had S&B SR primers...The first time it happened to multiple rounds,so removed bolt,cleaned,worked about the same--it's an obvious light strike as it mimics the pin strike when you drop the bolt on an AR...I'll put rounds back in and usually 2 or 3rd loading they fire...I was thinking,I've loaded the brass so many times that the pocket is messing up-but it would enlarge sideways not deep...Primers are set right .When it fires 8 in a row,all strikes are proper deep. Any thoughts?
 

·
Registered
Joined
·
1,367 Posts
Get on Savage Shooters website and ask this question. You will get a more definitive answer there.

I never had this issue with my Axis but have read about others that have. Sorry but I don't remember the fix.
 

·
Registered
Joined
·
4,239 Posts
I remember a rash of these on another forum. Some polished up the firing pin and the edges on a spacer washer?, some replaced the FP spring with a Wolff replacement that's 2-4lbs heavier.
 

·
Registered
Joined
·
5,160 Posts
Discussion Starter #4
Thx,I'll try those suggestions..
 

·
Registered
Joined
·
1,421 Posts
If you are shooting reloads & the primers are not set all the way into the base of the primer pocket it may not fire. The new primer has to seat in against the base of the primer pocket to get reliable ignition or it may just push the primer in a little farther each time you pull the trigger.
 

·
Registered
Joined
·
5,160 Posts
Discussion Starter #6
read the post
 

·
Premium Member
Joined
·
4,242 Posts
Is the firing pin protrusion adjustable like on a Savage 110? I had this problem with an older Savage.
 
  • Like
Reactions: BlackEagle
1 - 7 of 7 Posts
Top