The Firearms Forum banner
1 - 5 of 5 Posts

·
Banned
Joined
·
1,857 Posts
Discussion Starter · #1 ·
I have the model 25 varminter. i was shooting yesterday behind my house and was shooting some barnes and then some fusion. Out of around 20 shots, 3 of them wouldnt go off and the 3 cartridges that didnt go off didnt even have the base punched where the firing pin hits. The day before I was shooting some winchester .223 and I didnt have any problems with any of the cartridges. Is it something with the gun or do you think its the ammo? Also if you think its the gun could you tell me an idea of how should I go about fixing it.

Thanks for any help.
 

·
Registered
Joined
·
294 Posts
If the primers are good and dimpled, it is an ammo issue for sure. I have seen several gun brought into the shop for light hits and it turned out to be the ammo lately. Check to see if the primers are flush with the case or if they look like they are too deep. This has been a problem we have seen with some commercial loads lately.
 

·
Registered
Joined
·
74 Posts
I`m thinking that your gun has the accu-trigger, If so ,that could be the problem. My model 10 did the same thing untill I got used to it, If the silver coloured part of the trigger is pushed sideways at all, thr rifle will de-cock with a barely noticeable click. It will not dent the primer. some people say it`s a safety feature built into the trigger,others say it is caused by rolling your finger on the trigger instead of squeezing straight back. try it by dry firing the rifle and if you push the trigger to the side you will hear the same click, not nearly as loud as usual
 

·
Premium Member
Joined
·
3,073 Posts
I have a savage 25 in .223. love that triger.
no misfire problems with it but. did with my 25/06. factory ammo, same problum. primers set to deep.
thats why i reload all most all my ammo now.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top