Remington viper 522 won't fire.

Discussion in 'Technical Questions & Information' started by The-YanK, Dec 16, 2015.

  1. The-YanK

    The-YanK New Member

    Joined:
    Dec 16, 2015
    Messages:
    2
    Hi. I just recently picked up a 522 viper seems like a nice little gun. I'm not fond of all the plastic but nothing's ever perfect. And please spare me all the "it's junk" post Ive read enough of them already. I never said it was anything special. How ever I brought it home tore it down cleaned it up real gold reassembled it slide the magazine In and pulled the bolt back and I'll be damned if nothing happend. When u pull the trigger it's just mushy. Almost like the triggers not even connected. I've tore it down checked it out I'm no gunsmith but I'm pretty good with guns had a Marlin model 60 I've fixed countless times but this has me dumbfounded. Anyone have any advice or has ever had this happen before? Everything seems to work good bolt pulls back locks just no trigger it's like it doesn't hit anything. Please let me know your advice or thoughts Oh ye wise ones. Thank you.
     
  2. jedwil

    jedwil Well-Known Member Supporting Member

    Joined:
    Sep 11, 2009
    Messages:
    9,769
    Location:
    Texas Hill Country

  3. The-YanK

    The-YanK New Member

    Joined:
    Dec 16, 2015
    Messages:
    2
    Thank you for the reply I seen the video but it doesn't really help me. Everything was working fine so I don't believe it's a issue with the mag. It's like the trigger just doesn't touch anything when u pull it. No click no nothing just mushy. I checked a schematic and everything seems to be there just somethings not lining up or something. I'm not sure. I tore it back down and reassembled it according to the manual to the t but still the same problem.