The Firearms Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
i have a model 16 squires semi auto 22lr that I'm fixing for a friend now I've run into an issue.when I pull the bolt handle to cock the gun it will not cock or load back to give action to the trigger how can I fix this
 

·
Registered
Joined
·
3,376 Posts
That rifle is the earlier model of the Armscor M1600. I have one, as a guess without being able to look at it myself I'd say either grime and carbon has gotten down inside the action, or the sear portion is worn to where it won't catch. They are a bit of a pain to tear down completely, so a lot of times people just don't bother which leads to the buildup problem. Do a complete teardown and cleaning and inspection to start with. Here is a link to the owners manual and schematic. If you can't fix it, they do have a repair facility in Pahrump NV.

http://stevespages.com/pdf/armscor_1600.pdf
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
That rifle is the earlier model of the Armscor M1600. I have one, as a guess without being able to look at it myself I'd say either grime and carbon has gotten down inside the action, or the sear portion is worn to where it won't catch. They are a bit of a pain to tear down completely, so a lot of times people just don't bother which leads to the buildup problem. Do a complete teardown and cleaning and inspection to start with. Here is a link to the owners manual and schematic. If you can't fix it, they do have a repair facility in Pahrump NV.

http://stevespages.com/pdf/armscor_1600.pdf
Thank you very much as soon as I do I'll reply and give the outcome I greatly appreciate it
 
1 - 3 of 3 Posts
Top